Node.js

Supported Node.js versions

Versions More info
4.x here
6.x here
8.x here
10.x here
12.x here
14.x here

Web frameworks

Web framework Supported versions More Details
Express 4.x here
Fastify 3.x here
Hapi >= 17.0 here
Koa 2.x here
GraphQL Apollo Express 2.x here

Database clients

Client More info
MongoDB mongodb
Mongoose mongoose
MySQL mysql
redis redis
Sequelize sequelize
Sqlite3 sqlite3
PostgreSQL pg
Microsoft SQL Server mssql
Oracle oracledb
CosmosDB @azure/cosmos
CassandraDB cassandra-driver
DynamoDB aws-sdk/dynamodb
Couchbase couchbase

Your server is not on the list?

Contact us to ask for an integration at support@hdivsecurity.com