Python

Supported libstdc++ versions

The Python agent requires libstdc++ version 6.0.23 or greater. This is the version included with GCC7. Centos7 has a lower version but the newer one can be included with:

yum install -y centos-release-scl && yum install -y devtoolset-7
Then you can enable the new version before running the app with the command:

/usr/bin/scl enable devtoolset-7

Supported Python versions

Language Versions
Python 2 2.7
Python 3 3.6 - 3.9

Supported Web Frameworks

Web Framework Versions
Django 1.11 - 3.2
Flask 1.1.4 - 2.x

Supported Web Servers

Web Servers Versions
Apache2 / mod_wsgi 2.4.38 (Debian) / 4.7.1
Gunicorn 19.10.0 - 20.0.4
Nginx / uWSGI 1.14.2 / 2.0.19.1
Runserver Django 1.11 - 3.2

Your server is not on the list?

Contact us to ask for an integration at support@hdivsecurity.com

Database clients

Client More info
Mysql: Official Connector Any version
Sqlite3 Any version
PostgreSQL: psycopg2 Any version
MongoDB: Official connector Any version